Problem mit WHIRLWIND Pinball Machine - Williams 1990 startet nicht mehr

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Problem mit WHIRLWIND Pinball Machine - Williams 1990 startet nicht mehr

    Hallo Leute habe seit ein paar Jahren einen
    WHIRLWIND im Keller stehen.
    Ist immer gegangen bis vor kurzen .
    Wenn man einsteckt fährt er nicht hoch. Spannungen vom Trafoabgang habe ich schon angesehen ebenso die Sicherungen.
    Das einzige bis jetzt habe ich einen losen Draht von rechts unten (Gleichrichter )gefunden.

    Anbei einige Fotos und Videos.

    photos.app.goo.gl/RUgvdNxGUVvjtdRA2

    Danke für einen Tipp :) lg Tomsayer
  • Wenn die Adjust Anzeige dem aktuellen Zustand entsprciht sind die Batterien leer. 1x neu und mit offener Kassentür anstellen damit das ram neu beschrieben werden kann. Allerdings scheint er ein Problem mit der Anzeige zu haben. Ist das Flachbandkabel richtig herum aufgesteckt? Ansonsten evtl. ein Fehler auf der CPU oder Displayplatine.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Wahrscheinlich CPU und evtl die Displayplatine defekt.

    Ferndiagnose eher unmöglich.

    Blinkt die Diag LED auf der CPU kontinuierlich oder wird ein Blinkcode ausgeben?

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Wird keine große Sache sein. Man muß Sie nur finden :) Gute gebrauchte CPUs kosten mittlerweile um die 150-175. Reparatur ist sicher billiger.

    Wenn es nur die CPU ist dann deutet die fehlerhafte Anzeige auf ein Problem entweder mit U44 U51 hin aber das passt nicht zum Adjust Failure. Das ist eher ein Problem mit dem Memory Protect oder U25. Display Platine müßte man trotzdem schauen ob evtl. ein UDN6118A-1 defekt ist. Und dann gleich auch nochmal die Sicherungen auf dem Netzteil kontrolieren.

    Wenn du keinen Fachmann in der Gegend hast frag sonst mal Martin (Mr.Startrek.) Ich bin im Moment etwas zeitlos.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Ich bin aktuell im Urlaub und habe erst wieder Ende des Monats Zeit.
    Könnte die schon in den teststand reinhängen

    Frage zunächst - als er noch ging war dar auch die Display Anzeige korrekt?
    Sieht wie Frank sagt nach 2 fehlern aus

    Justagefehler ist normal wenn die Batterie leer ist oder hier Draht ab

    Würde zur Sicherheit mal die Spannung testen die von Deinem externen Batteriehalter zur CPU geht aber vermutlich eher ein IC Problem

    Martin
    Live Long and Prosper
  • ich würde da nicht mehr gorß rumprobieren. Softern ein UDN6118A-1 kaputt ist können es die 100V in die 5V schaffen. Die sind öfters mal kurzgeschlossen. Netzteilplatine könnte der Gleichrichter sein. 4,75 ist etwas untere Schwelle aber müßte eigentlich nioch gehen. ich würde Netzteil, CPU und Display zusammen überprüfen lassen.
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • So jetzt habe ich mal dasPower board durchgemessen.
    Bei den Eingängen

    3J3 bekomme ich
    bei 8/9 90,1 Vac
    bei 1,2 / 3,4 / 5,6 je 10.1 Vdc

    Bei den Ausgängen
    Bei stecker 3j1
    6,7,8,9 4,9 Vdc
    14,15 -14 Vdc ist das zuviel statt -12v ?
    11,12,13 11,6 Vdc

    Bei stecker 3j2
    5,6 5 vdc
    1,3 nichts da die sicherungen f1 und f5 fehlen (led display) ?

    Die bauteile am master display sind nicht vorhanden es wurde vom vorbesitzer umgebaut .

    Also könnte ich den bauteil u51, u44 und u25 bestellen und einlöten? Habt ihr gute Quellen ? Memory Protect sagt mir leider nix.

    Oder sollte ich noch was durchmessen ?

    Danke :)

    The post was edited 1 time, last by Tomsayer ().

  • Die Spannungen sind ok.

    Ich würde nichts auf gut Glück austauschen. Das macht den Fehler ggf, nur schlimmer wenn es dabei Leiterbahnen erwischt. Hast du Löterfahrung und eine temperaturgeregelte Lötstation?

    Ich hatte nicht gesehen das das Display umgebaut wurde. Der Fehler liegt also an der CPU oder dem umgebauten Display. Hatte die CPU mal einen Säureschaden?

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Die 6821 gibt es nicht mehr. Die meisten aus China die man heute kaufen kann sind umgelabelte Gebrauchtchips. Mal gehen Sie mal nicht. Ggf. in den Flippershops gucken. Für den 74154 kann man einen 74LS154 nehmen. HCT154 müßte hier auch gehen. U25 ist ein 6116. Ein 6264 geht bei 11B bis C auch sofern die Platinenrevision die zusätzlichen 4 Pins hat. Haben aber alle außer jemand hat eine 11A eingesetzt. Für das 6264 muß ein Jumper umgesetzt werden. Kann ich raussuchen. Hatte ich, glaube ich, auch mal bei pinwiki geschrieben.

    Ich würde trotzdem nicht auf Verdacht tauschen. Es kann auch ein anderer TTL Baustein irgendwo sein und wenn ich umgebaute Masterdisplayplatine lese dann weiß man auch nicht was da evtl. schief hängt...

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.