Bally 6803 CPU und beide PIA verstorben

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Bally 6803 CPU und beide PIA verstorben

    Hallo Allerseits.

    Ich habe momentan eine 6803 MPU auf dem Tisch, die plötzlich und unerwartet mitten im Spiel den Geist aufgegeben hat. Der Besitzer des Flippers hat versichert, nicht irgendwo herumgefummelt zu haben und es wurden auch kürzlich keine Reparaturen durchgeführt.
    Nach ersten Tests stellte sich heraus, dass beide PIA sowie die 6803 CPU mausetot waren. U6 (74LS373) wurde sehr heiß und flog darum auch raus. Nach Austausch der beiden 6821 und 6803 arbeitete die CPU wieder. Wegen des fehlenden 74LS373 (ist bestellt) habe ich noch nicht weitergehend getestet.
    Meine Frage in diesem Zusammenhang:
    Was kann die Ursache für diesen Ausfall sein? Es hat ja wenig Sinn, die reparierte MPU in den Flipper einzubauen, wenn man die Fehlerquelle nicht kennt. Das Powerboard habe ich überprüft (Gleichrichter, Spannungsregler, Kondensatoren durchgemessen) und die Lötstellen der Würfelstecker nachgelötet. An einigen waren deutlich Risse um die Pins herum zu sehen. Anschließend wurde das Powerboard erfolgreich in einem anderem Flipper dieses Systems getestet.
    Ich bin gespannt auf die Meinungen der Experten.

    LG,
    Michael

    Falls sich jemand wundert, warum ein identischer Thread in zwei Foren gleichzeitig erscheint:
    War ursprünglich nur hier geplant, ist aber versehentlich zuerst im Flippertreff gelandet. Das soll jetzt keine Abwertung des Flippertreff darstellen, hier ist jedoch die Aktivität deutlich höher und daher eine schnellere Lösung des Problems zu erwarten. ;)
  • Als Erstes die 5V prüfen. Hast du ja erledigt.

    Wenn ich das richtig deute ist der 373 ein Adresstreiber:
    pinwiki.com/wiki/index.php?title=Bally_6803

    Hat der intern einen Kurzschluß kann er zumindest die MPU zerstören wenn von dem die Adresspins dauerhaft auf Masse gezogen werden. Da sind die PIAs erstmal außen vor aber ist der Bus gestört kann das Auswirkungen auf alle Chips haben.

    Beliebt ist auch ein Eprom falsch herum einzustecken oder Spulen bzw. eine andere Spannung von außen in die Platine zu jagen und dann erstmal anlassen und gemütlich messen.

    PIAs von AMI sind z.B. auf den Williams Platinen auch eine beliebte Fehlerquelle. Der Pegel auf dem Bus ändert sich. Low ist nicht mehr 0V. Hatte schon mehr als eine Platine wo ich ohne Außenwirkung alle AMI Bausteine tauschen mußte.

    Trat der Fehler aus heiterem Himmel auf?

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Laut Besitzer des Pins mitten im Spiel. Vor einigen Wochen soll es sporadische Ausfälle mit wirren Displayanzeigen gegeben haben, danach soll das Gerät ohne Eingriff wieder normal funktioniert haben. Die PIA sind von Motorola, also würde ich die nicht verantwortlich machen. Es sieht für mich auch eher nach einem Schaden durch Überspannung aus, da die PIA komplett tot sind (getestet mit NeoLoch Inquisitor) und an der CPU noch nichtmal das Clock Signal zu messen war. Mit neuer CPU sieht es da wieder normal aus. Wenn ich den LS373 bekomme, stecke ich mal Leon's Testrom rein.
    Aber ohne die Ursache gefunden zu haben, kann man ja die reparierte Platine nicht wieder einbauen.
  • Hmm durchgeschlagene Displayplatine ist immer für sowas gut. ich kenne die Bally 6803 nicht. Auf den Williams Platinen kann das passieren wenn einer der UDN6118 durchbrennt. Schlägt dann auch gerne bis zum PIA auf der CPU durch insbesondere wenn zu hoch abgesichert ist.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Ich habe eben Meldung vom Flipperbesitzer bekommen:

    Zitat:
    "So,habe alle Kabel und Stecker kontrolliert,nichts!!

    Beim linken Display ist mir aufgefallen,das es hin u.her wackelt,und dabei gegen das hintere Blech anstösst,was nicht isoliert ist.
    Die weissen Klammern sind ausgenudelt,die das Display halten.beim spielen,wenn man an dem Kasten etwas wackelt,wackelt das Display ganz schön doll.
    Das könnte die Ursache sein." Zitat Ende

    Ich werde morgen mal im Verein an einem Gerät gleicher Bauart nachsehen, ob das tatsächlich als Fehlerquelle in Frage kommt.
  • HCT245 dürfte etwas schneller sein und weniger Strom verbrauchen. In der Schaltung sollte es total egal sein. HCT ist ja die TTL kompatible Variante.

    Klingt tatsächlich als ob es Überspannung auf den Bus geschafft hat. also würde ich die Displays bzw. die Ansteuerung mal genauer anschauen.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.