High Roller Casino Schalter werden nicht erkannt

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • High Roller Casino Schalter werden nicht erkannt

    Hallo,
    ich habe einen HRC in den Fingern bei dem Schalter 29 und 32 (Opto) nicht erkannt werden. D.h. im Schaltertest wird bei Betätigung der Schalter als geschlossen erkannt, aber es erklingt kein Bestätigungston und der Schalter wird nicht im Display angezeigt. Am Schalter 29 kommen von jeder Farbe 2 Kabel an. Diese habe ich abgeknipst und ohne Schalter farbenreich wieder verbunden. Schalter 32 geht dann immer noch nicht.
    Hat einer eine Idee?
    Ich tue nix, ich will nur spielen
  • Ja der Opto leuchtet rot und wenn ich den Lichtstrom unterbreche geht auf der Empfängerplatine die Bestätigung LED an. Schliesse ich an dem Stecker die beiden Switch-Matrix-Kabel kurz wird das von der CPU nicht registriert.

    Es kann durchaus sein, dass da schon mal was getauscht wurde. Das nicht funktionierende Standup-Target ist auch nicht original
    Ich tue nix, ich will nur spielen
  • den beide Schalter korrekt angezeigt.
    Die CPU hat für mich unbekannte Modifikationen erhalten, sieht aber ansonsten gut aus. (siehe Fotos)
    Images
    • sMxqSFGMQdqQkfA%Rkvdfw.jpg

      3.6 MB, 3,024×4,032, viewed 3 times
    • o268H6XuSHGhBTte3waJkw.jpg

      2.78 MB, 3,024×4,032, viewed 5 times
    • WRDMryjXTUSdYKXpm2N0Kw.jpg

      2.74 MB, 3,024×4,032, viewed 3 times
    Ich tue nix, ich will nur spielen
  • So richtig fällt mir da auch nichts ein wenn Sie registriert werden. Ist 3.0 installiert. Sieht nach einem must have aus sofern noch nicht drinnen:

    - Game plays and feels a lot faster now thanks to all this.

    - Switch scanning rewritten. Matrix still scanned 2 cols/ms, but all
    debouncing is done by exec now.

    - Fixed switches not dispatching if they closed and opened before exec
    had a chance to process them.

    - Added statistical analysis of switch closures, which allows detection
    of both hyper- and hyposensitive switches. It also allows software
    compensation for broken switches, based on legal opinion.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • So, Problem gelöst, allerdings ohne eindeutige Fehlerdiagnose. Mit dem Oszi waren für jede Schalterauslösung identische Signale an U203 und U205 zu messen. Q4 hatte identische Messwerte zu allen anderen Transistoren. Trotzdem Q4 erneuert und da das Ding schon mal auf dem Tisch lag, U205 (74HC245) und U401 (LM339) ebenfalls. Einen 74HCT273 für U203 hatte ich nicht da, sonst hätte ich den auch gemacht.
    Alle Schalter werden wieder korrekt erkannt.

    Gruß,
    Michael
  • Leider war die Freude nur von kurzer Dauer. :rolleyes:
    Nach ein paar Spielen dasselbe Problem. Also noch U203 erneuert, ein neues ROM gebrannt, die beiden CPU Chips untereinander getauscht und das RAM gecheckt.
    Platine wieder eingebaut, alles funktioniert einwandfrei. Mehrere Testspiele gemacht, mehrfach ausgeschaltet und wieder ein---> alles gut. Am nächsten Tag war dann nach einigen Stunden Spiel das Problem wieder da.
    Mein Kontingent an Ideen ist leider erschöpft (ein Kanister Benzin wäre vielleicht die Lösung :evil: ), was soll man noch tun?

    Michael
  • Users Online 1

    1 Guest