Eine geruhsame Adventszeit,
F r o h e   W e i h n a c h t e n   und
Einen guten Rutsch in's neue Jahr!
Bleibt Gesund und passt auf euch auf.

Jurassic Park von Data East diverse Probleme

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Jurassic Park von Data East diverse Probleme

    Hallo zusammen,

    mein erster Beitrag hier im Forum. Nein, eigentlich nach der offiziellen Vorstellung, mein zweiter Beitrag.
    Bin seit ein paar Tagen stolzer Besitzer eines Jurassic Park Flippers. Diesen habe ich von einem Freund bekommen. Das Teil stand jahrelang unbenutzt in seinem Keller im Hobbyraum.
    Das erste Einschalten nach langer Zeit offenbarte bereits erste Probleme. Der Flipper startet nicht richtig, braucht mehrere Anläufe und Gedenkminuten bis er spielbereit ist. Der Fehler war schnell gefunden, C2 im Netzteil war ausgelaufen. Alles gereinigt, neuer 100µF rein und startet er wieder perfekt.
    Bleiben noch zwei Probleme. Der rechte unter Flipperfinger hält nicht wenn die Taste gedrückt bleibt. Hier muss ich mal messen, ob die Haltespannung vorhanden ist.
    Meine Größte Sorge ist allerdings das Display. Es reagiert zwar auf den Spielverlauf, zeigt aber nur Müll an. Siehe auch angehängtes Bild. Es ist ein DOT-Matrix Display (GD-032D128-01) Der Controller hat die Nummer 520-5055-01 REV.D. Drauf steckt wohl ein EPROM mit der Bezeichnung JP 5.01..
    Mir ist jetzt nicht klar, wo der Fehler zu suchen ist. Ist das Display selbst defekt oder Display Controller? Ersatzdisplays sind sehr teuer und ich möchte hier nicht umsonst Geld ausgeben.
    Hat jemand Erfahrung damit? Bin für jeden Tipp dankbar.

    Viele Grüße
    Frank
    Images
    • 20201019_204803.jpg

      125.47 kB, 1,024×768, viewed 6 times
  • Solche Effekte treten u.a. auf, wenn Kontakte von Flachbandkabeln oxidiert sind. Häufig hilft dann schon mehrmaliges abziehen und wieder aufstecken der Stecker, speziell der zum Display gehenden Verbindungskabel.

    Falls das nicht zum Erfolg führt:
    Mal die Kontakte in Augenschein nehmen und ggf mit einem Glasfaserstift betroffene (oxidierte) Kontakte vorsichtig reinigen.
    Und nein: kein Kontaktspray verwenden!
  • Hallo Kuroda,

    Vielen Dank für deine Antwort. Die Kontaktstecker der Flachbandkabel sehen gut aus. Nur in die Buchsen kann ich natürlich nicht reinschauen. Ich habe mir mal neue Büchsen und Kabel bestellt um neue Kabel anzufertigen. Mal schauen, ob der Fehler dann weg ist.

    Viele Grüße
    Frank
  • Sieht nach einer defekten Horizontalansteuerung aus. Ist bei den Babcocks recht häufig zu finden. Die SMD Zenerdioden werden heiß und bruzzeln die Platine weg. Miß mal die Spannungen direkt am Display und mach mal ein Foto von der Rückseite in der Nähe des Steckers für die Spannungsversorgung. Nicht zu lange so betreiben. Streßt den HV Teil auf dem Netzteil ziemlich.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Guten Morgen FRG,

    Danke für deinen Tipp, beim Röhrenfernseher hätte ich jetzt gesagt, dass die Vertikalablenkung fehlt. Das Display zeigt tatsächlich auch nur um unteren Bereich etwas an. Dioden habe ich nur eine gefunden, die ist messtechnisch i.O. und die Platine sieht nicht danach aus, als hätte sie viel Hitze abbekommen. Um unter die Platine zu schauen, müsste das DMD ausgelötet werden. Bei meinem Lötequipment kann ich es danach gleich wegschmeißen. :D Ich baue heute wieder alles zusammen und messe mal die Versorgungsspannungen.

    Viele Grüße
    Frank
    Images
    • 20201022_080911.jpg

      2.71 MB, 3,024×4,032, viewed 10 times
  • Miß mal die Widerstandswerte R174 bis R178. ich hatte schon mal einen kaputten Widerstand. Ansonsten ist da Ende Gelände ohne Austauschplatinen und/oder Osziloskop.

    Wenn du ein Osizi hast miß mal an den Ausgängen von U5. Kann man ja direkt an den Pins vom Display machen. Da müßte ein T Signal anliegen. Schon länger nicht mehr gemessen. Kann auch ein umgekehrtes T sein aber ich glaube nicht.

    Die Displays mit dem Optokoppler sind nicht so empfindlich aber es kann sein das U5 und/oder der Optokoppler defekt sind. Eine kaputter DMD Controller kann das auch verursachen aber meistens bleibt das Display dann dunkel.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Die Widerstände habe ich auch geprüft, alles im grünen Bereich. Teste morgen Display und Flachbandkabel bei einem Bekannten, der auch einen Data East Flipper hat. Sollte wirklich das Display defekt sein, besorge ich mir den U5 IC SN75558FN und den Optokoppler und tausche die mal. Falls das nichts bringt, dann muss halt ein neues Display her.

    VG
    Frank
  • Die sind eigentlich immer reparabel. hatte mal 10 oder so für einen Freund gemacht der sich dann neue Gläser gegönnt hta. Ein paar liegen hier immer noch aber ich habe keine Lust :)

    SN75558FN ist nicht mehr lieferbar. Bei Chinaware gucken welcher Verkäufer. Da fliegen insgesamt viele Fälschungen rum aber bei PLCCs seltener.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.
  • Display geht wieder, bis auf die letzte Zeile vertikal ganz rechts. Stört mich aber nicht weiter.
    Der Optokoppler war das Problem.
    Jetzt muss ich mich noch um die Haltespannung für den Flipperfinger rechts unten kümmern, ein bisschen Beleuchtung machen, dann kann der Flipperspaß so richtig losgehen.

    Viele Grüße
    Frank
  • Ist ein Babcock Display. Da brechen gerne mal die Kontakte direkt am Glas. Das bekommt man aber meistens gut geflickt wenn es nur eine Spalte ist. Isoliermasse vorsichtig ankratzen und Draht anlöten. Natürlich nur wenn da eine sichtbare Bruchstelle ist.

    FRG
    Technische- und Reparaturanfragen per pm ohne vorherigen Forumsthread werden nicht beantwortet.